CYPHER for Business US Search

Incident Report for CYPHER Learning

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 20:49 UTC

Identified

Some customers are experiencing issues with our search functionality on CYPHER for Business in the US. We are working on this and expect to have it resolved soon.
Posted Jul 01, 2026 - 19:20 UTC
This incident affected: CYPHER for business.