Cypher Support Unavailable

Incident Report for CYPHER Learning

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 10:09 UTC

Investigating

We are currently experiencing a major outage affecting Cypher Support. The issue is due to a widespread outage with our third-party support provider, Zoho Desk.

Our team is actively monitoring the situation, and we will provide updates as soon as the service is restored.

You can track Zoho Desk’s incident status directly here:
https://status.zoho.com/

We apologize for the inconvenience and appreciate your patience.
Posted Oct 15, 2025 - 08:18 UTC
This incident affected: CYPHER for academia, CYPHER for business, CYPHER for entrepreneurs, CYPHER for academia EU, CYPHER for business EU, CYPHER for academia AU, and CYPHER for business AU.